DDoS Attack on Imperva’s Legacy Bot Protection Public Cloud
Incident Report for Distil Networks
Resolved
This incident has been resolved.
Posted May 20, 2020 - 21:00 UTC
Monitoring
The issue has been addressed and we are currently in monitor mode.
Posted May 20, 2020 - 20:20 UTC
Identified
The source of the attack has been identified and we have taken steps to mitigate the impact of the attack. Services should be returning to normal.
Posted May 20, 2020 - 19:57 UTC
Update
The DDoS attack has resumed against our Legacy Bot Protection Global Cloud and we are continuing to actively investigate. You may experience latency in your web site load times as well as temporary outages.
Posted May 20, 2020 - 18:56 UTC
Investigating
Imperva Legacy Bot Protection was the target of a DDoS attack between 5:14 PM UTC and 5:35 PM UTC. We are still investigating to determine the source of the attack to ensure future attempts are blocked. We will update with additional information as it becomes available.
Posted May 20, 2020 - 18:25 UTC