Email channel to Distil Support is unavailable
Incident Report for Distil Networks
Resolved
This issue is now resolved. Emails to support@distilnetworks.com are now reaching Distil's ticketing system without a delay.
Posted May 21, 2019 - 13:50 UTC
Update
Emails to support@distilnetworks.com are still delayed. You may use an alternative email address when reaching out to Distil Support. The alternative email is help@distilnetworks.com.
Posted May 15, 2019 - 16:42 UTC
Update
Distil is receiving emails to support@distilnetworks.com, however tickets that are submitted via email are delayed. Please continue to use the following URL for submitting tickets.

https://help.distilnetworks.com/hc/en-us/requests/new
Posted May 14, 2019 - 19:35 UTC
Identified
Distil received a large volume of emails to our support email address this morning EST resulting in rate limiting at our email provider. It is still possible to continue submitting tickets to the help center in the link below:

https://help.distilnetworks.com/hc/en-us/requests/new

The email rate limit will be lifted within 24 hours.
Posted May 13, 2019 - 16:06 UTC